Apple iPhone 3GS Not Compatible With iOS 5.0 – iPhone 4 Is

The Internet has been riddled with speculation and expectancies of both the design and features of the new Apple iPhone 5 (4GS) but something that people haven’t thought too much about is the version of iOS that it will run on. We already know that Apple is readying itself for WWDC which will be a software only event where we expect they will be showcasing the new iOS 5.0.

Whilst the iOS 5.0 is yet to be confirmed you have to wonder why they would hold such a bit event without a device being present for it. Whilst we are on the subject of that new iOS we have just read an entry over on iClarified that talks about other devices being able to take advantage of the new iOS. The report says that the Apple iPhone 3GS will not be compatible with iOS 5.0 but the iPhone 4 is.

They have used macstories.net as a source where Federico Viticci has added a report about the rumor. He refers to a previous report where Apple was apparently trialing the new iOS on iPhone 3GS models although it wasn’t clear that they would get it when it went public.

The reason that all of these rumors have come about is because of a Tweet that came from Eldar Murtazin who is the editor-in-chief analyst of Mobile-Review. He Tweeted “Apple iPhone 3Gs wont be upgradable to iOS 5.x. iPhone 4 will.” Check it out on this link or alternatively in the image below.

Do you think the Apple iPhone 3GS will be compatible with the latest iOS? Let us know in the comments section below.